• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS ADE 2020 Alpha 18 Released

Messages
107
Country
unitedstates
Yes, ADE has the correct paths to the configs, SDK and to the content root folder, which on my machine is a custom location: “E:\Content” and which contains Community and OneStore.

Alpha 14 was working with Navigraph present, but it has been a while since I last used it, and I uninstalled it before installing Alpha 18.

The. Navigraph installer does modify Content.xml so that its files are layered correctly in the overall scenery system, so perhaps that is what is causing the issue.

With Navigraph present, ADE will throw the error message about “Base file missing” when creating a new project using a stock airport. Merely running the Navigraph uninstaller will allow ADE to create new stock projects with no errors.

It’s not a major problem. I was curious though if you had received other reports of this problem.
Just a suggestion.
Set the properties of your MSFS folder to "not hidden" and not "Read Only" and run ADE as Administrator.

George
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
33,827
Country
unitedkingdom
Yes, ADE has the correct paths to the configs, SDK and to the content root folder, which on my machine is a custom location: “E:\Content” and which contains Community and OneStore.

Alpha 14 was working with Navigraph present, but it has been a while since I last used it, and I uninstalled it before installing Alpha 18.

The. Navigraph installer does modify Content.xml so that its files are layered correctly in the overall scenery system, so perhaps that is what is causing the issue.

With Navigraph present, ADE will throw the error message about “Base file missing” when creating a new project using a stock airport. Merely running the Navigraph uninstaller will allow ADE to create new stock projects with no errors.

It’s not a major problem. I was curious though if you had received other reports of this problem.
No this is the first. As a matter of interest how does one get Navigraph for MSFS?
 
Messages
43
Country
us-newyork
Just a suggestion.
Set the properties of your MSFS folder to "not hidden" and not "Read Only" and run ADE as Administrator.

George
The MSFS folder is fully accessible and not read only, and I always run ADE as admin.

The more I think about it, the more certain I am that this has to do with how Navigraph is setting its priority in content.xml. It has gone through a few iterations of how it sets its priority over the default scenery for navaids and airports. There was a point where there would be doubled runways or other anomalies between default airport data and Navigraph that was changed by modifying the priority.

It’s not a big problem. It is easy enough to temporarily uninstall Navigraph if I want to work on a default airport in ADE.
 
Messages
43
Country
us-newyork
No this is the first. As a matter of interest how does one get Navigraph for MSFS?
If you are a Navigraph subscriber and have access to their forums, you can download the installer for the beta nav data for MSFS from the dedicated MSFS forum. Their other FMS AIRAC products for FSX/P3D/XP are all managed by a dedicated database manager program, but the MSFS core nav data has it’s own stand-alone installer/uninstaller. It copies all of its revised files to the community folder.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
33,827
Country
unitedkingdom
If you are a Navigraph subscriber and have access to their forums, you can download the installer for the beta nav data for MSFS from the dedicated MSFS forum. Their other FMS AIRAC products for FSX/P3D/XP are all managed by a dedicated database manager program, but the MSFS core nav data has it’s own stand-alone installer/uninstaller. It copies all of its revised files to the community folder.
Thanks - I don't have a sub for them but I might do so especially if their packages etc can 'interfere' with the operation of ADE.
 
Messages
176
Country
germany
Hi Scruffyduck, I have tried to load project from my bgl file which contains a simple helipad with a simple airport, runway, apron and some scenery elements but getting an error "surface" element...
I have send the error report from ADE recently. I'm using version 18. Here are my files.
 

Attachments

  • DRFU.bgl
    55.1 KB · Views: 24
  • DRFU.zip
    3.5 KB · Views: 33
Messages
54
Country
us-northcarolina
Is there a way to access the gen_hangar objects with ADE 18. I don't see any of them listed in the Library Object Manager. I understand that this is an Alpha release and many things are not available yet.
 
Messages
176
Country
germany
Is there a way to access the gen_hangar objects with ADE 18. I don't see any of them listed in the Library Object Manager. I understand that this is an Alpha release and many things are not available yet.
To extend the object list, go to library manager and use add file or add folder to add objects from the bgl files you add through the functions.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
33,827
Country
unitedkingdom
It depends where these come from. ADE 2020 does not support earlier version (mdl) objects since they are depreciated in the sim.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
33,827
Country
unitedkingdom
Hi Scruffyduck, I have tried to load project from my bgl file which contains a simple helipad with a simple airport, runway, apron and some scenery elements but getting an error "surface" element...
I have send the error report from ADE recently. I'm using version 18. Here are my files.
I don't know the source of this but the runway surface is a zero guid. I can load the bgl file with the error you get. I created a new project with the bgl file and saved it - that seemed to repair the issue
 
Messages
176
Country
germany
I don't know the source of this but the runway surface is a zero guid. I can load the bgl file with the error you get. I created a new project with the bgl file and saved it - that seemed to repair the issue
Thx, I tried to create from bgl but still got the error. I'll try again...
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
33,827
Country
unitedkingdom
you will. create the new project, ignore the error and save the project. when you open it again it should have cleared the problem
 
Messages
176
Country
germany
Worked fine, and the default size of a library object which is surrounded by a square and in the object edit window there is a size of 20x20 meters grayed out. Any chance to change that or is is defined in the object library?
 
Messages
54
Country
us-northcarolina
To extend the object list, go to library manager and use add file or add folder to add objects from the bgl files you add through the functions.
I have added other bgl files to the library manager so I am aware of that. The problem is that I don't have a clue where to find the Asobo bgl file that contains the gen_hanger objects. I know that they exist in some file, just don't know which one.
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
4,654
Country
us-wisconsin
I have added other bgl files to the library manager so I am aware of that. The problem is that I don't have a clue where to find the Asobo bgl file that contains the gen_hanger objects. I know that they exist in some file, just don't know which one.
D:\MSFS\Official\Steam\asobo-modellib-airport-generic\scenery\airport_generic

(for the Steam edition)

When adding to the LOM be sure to Save after they are found.
 
Messages
54
Country
us-northcarolina
D:\MSFS\Official\Steam\asobo-modellib-airport-generic\scenery\airport_generic

(for the Steam edition)

When adding to the LOM be sure to Save after they are found.
OK I got that loaded and it is exactly what I wanted. One problem, each item gave me an error generating the footprint so all are represented by a square. Makes it a bit hard to position.
 
Messages
586
Country
us-florida
OK I got that loaded and it is exactly what I wanted. One problem, each item gave me an error generating the footprint so all are represented by a square. Makes it a bit hard to position.
That's funny. I imported the file also, and footprints look good.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
33,827
Country
unitedkingdom
That's funny. I imported the file also, and footprints look good.
Yep - they worked here fine as well. What error message? can you take a screenshot? Also please be sure that Draw Detailed Footprints is checked in Program Options

1618204398064.png
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
33,827
Country
unitedkingdom
Hmmm - well I can't answer that other than it is an error coming from Arno's code. I assume you created a new installation for Alpha 18 and didn't update an existing one?

I am getting an update to Arno's files for the next alpha. Maybe someone else will report this also and help us to replicate the issue
 
Top