• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Another Compiler Error (Different One This Time)

Messages
57
Country
ca-ontario
Hey all,

After not being able to add and recompile the ORBX scenery I redid the stock airport. This time I got farther in the compiling process like last time. Can't figure out where I'm going wrong here. Here is the error this time -

Thanks in advance,
Ryan

1630097064301.png
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,671
Country
unitedkingdom
OK - what you have is a mismatch of version and compiler. Follow the path in your ADE Settings for Your SDK. Settings > Options > BglComp Folder

1630127231305.png


1630127374692.png


What is the date stamp and size of BgkComp.exe.

Second please attach your ADE project file (.ad4) to a post here.
 
Messages
57
Country
ca-ontario
OK - what you have is a mismatch of version and compiler. Follow the path in your ADE Settings for Your SDK. Settings > Options > BglComp Folder

View attachment 76457

View attachment 76458

What is the date stamp and size of BgkComp.exe.

Second please attach your ADE project file (.ad4) to a post here.
Here is the BGLComp. The only reason I'm using the p3d one is because the steam edition sdk's are incomplete.
Here is the dropbox link for the files :) https://www.dropbox.com/sh/tw7t07z304blnpa/AABvB63Ud7WFdeXZHS1EZ8fYa?dl=0
Also the ramp on the field is totaly fictional. I just wanted to add it so my VA could have some decent ramp space and I'm also going to replace those FBO Buildings with large hangars too.

1630147308490.png
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,671
Country
unitedkingdom
It compiles here without error. including the Custom GP. This really seems to come down to the compiler or the xsd schema

I don't understand why you are getting such an error with the ADE_GP.Xml. Can you zip that and attach it to a post. Also make a copy of your project and remove the custom GP line - try to build it again
 
Messages
57
Country
ca-ontario
It compiles here without error. including the Custom GP. This really seems to come down to the compiler or the xsd schema

I don't understand why you are getting such an error with the ADE_GP.Xml. Can you zip that and attach it to a post. Also make a copy of your project and remove the custom GP line - try to build it again
ok I will. Here's the link for the ADE_GP.xml - https://www.dropbox.com/s/crj3skgzkvaadmo/ADE-GP.xml?dl=0
I'll try and I'll remove the gp line and get back to you in a minute :)
 
Messages
57
Country
ca-ontario
No luck there. I tried deleting the ADE_GP.xml and deleting the line in it but it didn't work. Could you put the compiler that you are using in a dropbox just so I can get this to work? I just wish that the FSX:SE SDK's were actually complete and I don't have to use the p3d ones. Thank you so far :D
 

Pyscen

Resource contributor
Messages
2,813
Country
us-texas
You shouldn't have any trouble with the P3D SDK v1.4 with FSX: SE. As Jon mentioned, it appears you are trying to compile with the incomplete SDK that came with Steam and the P3D SDK v1.4 ( using parts of each). Have ADE point to the P3D SDK v1.4 only.
 
Messages
57
Country
ca-ontario
You shouldn't have any trouble with the P3D SDK v1.4 with FSX: SE. As Jon mentioned, it appears you are trying to compile with the incomplete SDK that came with Steam and the P3D SDK v1.4 ( using parts of each). Have ADE point to only the P3D SDK v1.4 only.
ok will do 👍
 
Messages
57
Country
ca-ontario
You shouldn't have any trouble with the P3D SDK v1.4 with FSX: SE. As Jon mentioned, it appears you are trying to compile with the incomplete SDK that came with Steam and the P3D SDK v1.4 ( using parts of each). Have ADE point to the P3D SDK v1.4 only.
I still have that error unfortunatly. Downloaded and installed the P3D V1.4 and got ADE to use those tools in that folder. I also replaced the FBO hangars with the stock ones in the library objects. I'm really confused at this.
1630338273417.png
 

Pyscen

Resource contributor
Messages
2,813
Country
us-texas
Please show in configuring the SDK (where you have configured the current SDK). Also, share the ad4 file, please.
 
Messages
57
Country
ca-ontario
Please show in configuring the SDK (where you have configured the current SDK). Also, share the ad4 file, please.
In regards to configuring the SDK these are the directories -
1630355571389.png
I also got the P3D v1.4 from the link in this thread here - https://www.fsdeveloper.com/forum/threads/p3d-v1-4-sdk.446197/
And here is the ad4 file in the dropbox - https://www.dropbox.com/sh/83cw1848p5xah63/AABkT7our7agDotYfXTL_w0va?dl=0
Thank you soo much for being patient and helping me with this interesting issue 👍
 

Pyscen

Resource contributor
Messages
2,813
Country
us-texas
Why through the New User Wizard? (maybe to show the folders entered). Go to Settings -> Options -> Folders and make sure the "BglComp Folder" is filled in along with "Ship2Vec Folder". Make sure to click on the "Save" button. Both need to be pointed to the P3D SDK v1.4.

I had "no problems" in compiling from either the FSX SDK or the P3D SDK v1.4. Next, try removing the GroundPoly from the ad4 file and save it and compile.
 
Messages
57
Country
ca-ontario
Why through the New User Wizard? (maybe to show the folders entered). Go to Settings -> Options -> Folders and make sure the "BglComp Folder" is filled in along with "Ship2Vec Folder". Make sure to click on the "Save" button. Both need to be pointed to the P3D SDK v1.4.

I had "no problems" in compiling from either the FSX SDK or the P3D SDK v1.4. Next, try removing the GroundPoly from the ad4 file and save it and compile.
Ok will do and I will get back to you shortly
 
Messages
57
Country
ca-ontario
Why through the New User Wizard? (maybe to show the folders entered). Go to Settings -> Options -> Folders and make sure the "BglComp Folder" is filled in along with "Ship2Vec Folder". Make sure to click on the "Save" button. Both need to be pointed to the P3D SDK v1.4.

I had "no problems" in compiling from either the FSX SDK or the P3D SDK v1.4. Next, try removing the GroundPoly from the ad4 file and save it and compile.
What is a groundpoly? I'm not too sure what that is. I'm sorry about that
 

Pyscen

Resource contributor
Messages
2,813
Country
us-texas
Do you mean you didn't do anything with the runaway, railways and roads? What I suggest you do is start from scratch and only using the P3D SDK v1.4 from now on. As a test, load up a default airport and save it to a ".ad4" file, and then try to compile.
 
Messages
57
Country
ca-ontario
Do you mean you didn't do anything with the runaway, railways and roads? What I suggest you do is start from scratch and only using the P3D SDK v1.4 from now on. As a test, load up a default airport and save it to a ".ad4" file, and then try to compile.
I just opened up a stock airport in the stock airport menu in the files. Saved the airport as an ad4 and tried to compile with no luck. Got this error -

Compiler Errors Found. These were not identified by the Issue Manager. Please let us know
what the compiler error is so that we can improve the Issue Manager.

The compiler message is shown below

ScruffyDuck Scenery Design Engine Compiling
Using BglComp....


Parsing document: G:\Ryan\ADE\!AdeTempWorkOnly\CYEE_ADEX_RCG.xml

ERROR C2106: Improper value string for a library object name! ({7f38bfbc-e295-4a40-845c-3f3c872cfa82})
ERROR C2031: Failed element parse <LibraryObject>
ERROR C2032: XML Parse Error! Element tree follows:

ERROR: <FSData
ERROR: version = 9.0
ERROR: >
ERROR: <SceneryObject
ERROR: lat = 44.692972227931
ERROR: lon = -79.931369125843
ERROR: alt = 0.0M
ERROR: altitudeIsAgl = TRUE
ERROR: pitch = 0
ERROR: bank = 0
ERROR: heading = 150.325927734375
ERROR: imageComplexity = VERY_SPARSE
ERROR: >
ERROR: <LibraryObject
ERROR: name = {7f38bfbc-e295-4a40-845c-3f3c872cfa82}
ERROR: scale = 1.00
ERROR: >
ERROR:
ERROR C2309: RandomAttach is NOT a valid token!
ERROR C2016: Invalid element found <RandomAttach>, skipping!
ERROR C2032: XML Parse Error! Element tree follows:

ERROR: <FSData
ERROR: version = 9.0
ERROR: >
ERROR: <SceneryObject
ERROR: lat = 44.692972227931
ERROR: lon = -79.931369125843
ERROR: alt = 0.0M
ERROR: altitudeIsAgl = TRUE
ERROR: pitch = 0
ERROR: bank = 0
ERROR: heading = 150.325927734375
ERROR: imageComplexity = VERY_SPARSE
ERROR: >
ERROR: <AttachedObject
ERROR: attachpointName = attachpt_beacon
ERROR: pitch = 0
ERROR: bank = 0
ERROR: heading = 0
ERROR: >
ERROR:
ERROR C2309: RandomAttach is NOT a valid token!
ERROR C2023: Improper ending element <RandomAttach>. Stopping!
ERROR C2034: XML Parse Fatal Error (line, column, error)

ERROR: 152, 29, Unspecified error

ERROR C2470: Unrecoverable error parsing XML!
ERROR C2006: Parse failed (0x80004005)
ERROR C2003: Failed to process file: G:\Ryan\ADE\!AdeTempWorkOnly\CYEE_ADEX_RCG.xml

I'm sorry that my ade version is all jacked up and thank you soo much for trying to help me too 🙏
 

Pyscen

Resource contributor
Messages
2,813
Country
us-texas
Are you trying to open a ".bgl"? That is not a default airport if you are.
 
Messages
57
Country
ca-ontario
Are you trying to open a ".bgl"? That is not a default airport if you are.
no I just went to file > open stock airport and typed in the ICAO of my home airport, in this case CYEE. then I just went to file > save airport as then just saved it to my desktop and then tried to compile with the compile button in file. It's defenetly a stock airport lol.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,671
Country
unitedkingdom
All these errors are from the same source error which is almost certainly the compiler and schema. However I am totally unable to replicate it and am out of ideas as to what else to offer. Just to confirm that when you start ADE you select FSX from the selector

1630418328651.png


Or is it loading straight in. Do you have any parts of the original FSX in your computer or is FSX:SE the only one? Are there any versions of P3D lying around?
 
Messages
57
Country
ca-ontario
All these errors are from the same source error which is almost certainly the compiler and schema. However I am totally unable to replicate it and am out of ideas as to what else to offer. Just to confirm that when you start ADE you select FSX from the selector

View attachment 76520

Or is it loading straight in. Do you have any parts of the original FSX in your computer or is FSX:SE the only one? Are there any versions of P3D lying around?
I just have FSX:SE. I can't P3D is a little to rich for my blood lol and the original FSX is before my time. where is the Choose FS Version Selector? I don't get select version from when I start up
 
Top