• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Giving up in sheer frustration !!

Newbie to FSX development. I have read dozens of 'How to....', watched vidoes until my eyes are square.
I just can't figure out what is wrong and now on the verge of giving up and reverting back to X-Plane development where it works everytime with just a few mouse clicks.

So here's what I've done (several times)
1. Download & installed: ModelConverterX, ADE, Library creator, Prepare3D SDK kit (only got FSX SE). - no problems all installed correctly and BGL paths etc paths completed.
2. Create a model in sketchup (with 1 texture sheet to the power of 2) - Note: The model exports perfectly to X-Plane.
3. Exported from Sketchup in COLLADE format. - No problems
4. Imported into MDX
5. Model appears in MDX with all textures applied.
6. Used the wizard for Conversion and placement.
7. Nothing shows in FSX though all the files appear in my scenery and texture folders.

That was one way, also tried..

1. With the same .dae file I exported from MDX as a MDL file
2. In Library creator, created a library using the MDL
3. In ADE, added the Library and placed the object in place. - no problems.
4. Compiled the airport - no problems
5. Nothing shows in FSX, I know its my airport scenery being loaded as I added a taxi sign with my name on it in ADE.

If I add a stock library item in ADE it appears in FSX.
I exit FSX between each compile
File structure:
FXS Root
/Scenery/EGNC_ADEX_AJ.BGL (my airport file)
/Scenery/EGNC_OBJ_LIB.BGL (my Object Library)
/Scenery/Main_Admin.BGL (my building)
/Texture/ Chris_Skin.dds (my silly named texture file)

I have unistalled and reinstalled everything (except FSX), deleted all files a few times.
Unchecked the scenery area in FSX a few times
Checked scenery integrity with SceneryConfig editor.

Also tried with other custom buildings - same result or rather no result.
I feel as if I'm banging my head on a brick wall !
Am I doing anything fundamentally wrong, if not what could cause this not to happen.

Attached is a pic of what the building should look like (Taken from x-plane)
What happens if you load your object library back into ModelConverterX?

BTW, nice looking building.

And you are probably missing a simple step as this stuff works all of the time for others.

Also, what is your texture dimensions?
Last edited:
When I started years ago, I found exporting to be pretty fussy, but like Lane says, once you get it working it works consistently. I'll bet there are folks here that use sketchup also, and would be happy to detail the process that works for them.

One thing I'll share (ok maybe two) from the mistakes I've made.....so the model just wouldn't display in fsx no matter how often I beat my head into it.....once the cause was I had mistakenly set the complexity factor to extreme, but was testing in fsx at a lower complexity level. A second time with a similar problem, I found that I forgot the negative sign on my longitude setting..the model was INDEED displaying, but on the other side of the world from what I was expecting.

Good luck!
When importing the BGL into MDLX, I get a warning:
02:13 MDLXReader Warning Unsupported RIFF section: SGBN

But the model looks Ok with all the textures applied.
The texture dimensions are 4096x4096 (the max allowed in X-plane). I appreciate this is big.

Since you mentioned the texture size, I quickly created a new model (a simple box) in Sketchup, created a texture sheet (1024x1024) in Photoshop, applied texture to model, then followed the exact same process as mentioned above. Everything went through ok, files placed into right places etc, but nothing in FSXSE.
Bob, Thanks for comments.
In MDLX the DefaultImageComplexity is set to VERY_SPARSE. I have my scenery complexity in FSX at Max (ExtremelyDense). Not changed any settings in MDX. Is there a setting I'm missing during the convert process that I may have missed ?
For placing I use the map function in MDLX anbd ADE so I haven't entered any coordinates manually. Doubled checked coordinates after using map and it is inserting the correct coordinates with the negative sign.
4096x4096 is OK for FSX, that is the max size allowed.

If you placed the model with ModelConverterX (MCX) you should be able to load the .bgl back into MCX and click on the Object Placement tab, then verify that it is in the correct place.

If you use ADE to place it, then it should compile properly.

I have created dozens of models in Sketchup and never had a problem getting them in FSX. However I don't use the Convert and Place Wizard. My work flow is a bit different.

One common mistake is naming ...\FSX\AJ_Scenery\EGNC\Textures instead of texture.

If the texture format is incorrect the model will not display in FSX. Are you using MCX to convert the texture?

Which version of MCX are you using? If you are using 1.3 you should try 1.4. And get a fresh version.

If you load your object library .bgl in MCX and check the Material Editor, on the Properties tab, scroll down to the Textures section and check the Diffuse texture name, does it by chance show a path and not just the texture name?

In your FSX.cfg you can add the following 2 lines to the [SCENERY] section...


...and test. FSX will warn you if it can't find models and/or textures. Note you will want to change those to =0 for everyday use to avoid unwanted interruptions when flying.

Stick with it and we will figure this out.

I don't see it mentioned so I will ask if you have placed your .bgl and textures in an active addon scenery folder, or if you had activated your scenery in the FSX-SE scenery Library?
Failing to activate the scenery folder will result in no result.

don't should the 4096 textures be reflected in the fsx.cgf file ? To place objects I usually use the SDK Object Placement Tool. is a straightforward way to see if the object exist but it's a Little buggy and have to get the guid to be able to find the object but one can control all those bugs. And don't worry once you know where is the issue. exporting and placing sceneries is a trusty process.
don't should the 4096 textures be reflected in the fsx.cgf file
Not a requirement.

If the texture has no mipmaps it will display at full res.

If the texture has mips and TEXTURE_MAX_LOAD=4096 is not declared in the FSX.cfg the texture will be displayed at no more than the 1024 mip in the sim.

And that is for FSX Boxed only.

FSX Steam (which the OP is using) has TEXTURE_MAX_LOAD=4096 as a default. One of the Steam fixes.

You say you're using the P3d SDK, which version is it? For the models to be FSX compatible it needs to be the SDK for P3d v1, not v2 or v3.
Hi Guys,
Thanks for all the advice and time each of you have spent with my problem.
I'm pleased and relieved to report that the main problem has been resolved. !!!
Thanks Dave !! The answer was the wrong P3d SDK. I was using V3, I have now replaced V3 with V1 and my objects now appear.
Still got one or two problems with Textures on some of my objects, but I feel this is a sketchup problem and the way it exports the Materials. ie In the export file(s) I'm getting numerous texture PNG's. whereas as far as I am concerned I only used one per model (which is an x-plane restriction).
A screenshot of some of my models at EGNC...a long way to go,
I've reserved a parking slot for Dave/Lane. :)


Looking very nice!

Still got one or two problems with Textures on some of my objects, but I feel this is a sketchup problem and the way it exports the Materials. ie In the export file(s) I'm getting numerous texture PNG's. whereas as far as I am concerned I only used one per model
If you have to stretch your texture when mapping it in SketchUp then you will get those extra textures.

One simple rule is to not use the yellow pins. When using the Fixed Pins also stay away from the yellow pin and be careful with the blue pin. SU has some limitations in texture mapping and works best, IMO, if your textures are properly squared away before you apply them in SU.