• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

P3D v3 [SOLVED] ADE does not compile GP with specular textures. (or bump)

It did not work Don. The speculuar and bump continue to be moved to the correct scenery folder, but they will not "attach"to the bgl model.

In addition, within the GP module, I can no longer move/rotate the polygon when I select all vertices (or even a single vertex).
 

gadgets

Resource contributor
The speculuar and bump continue to be moved to the correct scenery folder, but they will not "attach"to the bgl model.
What do you mean by "attach"? On my system, the additional textures appear in the TEXT block of the .mdl inside the .bgl. Did you select the correct material in the GP Editor?
I can no longer move/rotate the polygon when I select all vertices (or even a single vertex).
Confirmed. It was working for me a few days ago.
 

gadgets

Resource contributor
You didn't explain what you meant by "attach". ADE_GP lists the three textures in, and copies your material specification into, the .mdl file which then forms part of the _GP .bgl.

It does not check the material specifications since it has no way of knowing what you intend other than by the specifications themselves. Only you can ensure they reflect your intent. Incidentally, that material was not included in the files you sent earlier.

What more do you expect ADE_GP to do or how else do you believe the .bgl is deficient?
 
Disregard Don, the GP.bgl worked fine with your fix. The only open issue is the manipulation of the vertices.

Thanks a lot for your help!
David
 
Last edited:

gadgets

Resource contributor
The OP before you declared the problem fixed, so I'm a little reluctant to rely on anything they said.

In any case, the attached fixes the vertex "drag" problem in the GP Editor. As well, I have confirmed that if:
  1. a custom material has been created, and
  2. that material is assigned to the GP in the GP Editor, and
  3. the airport compiles without error, that
  4. in the .mdl file forming part of the _GP.bgl:
  5. the TEXT block includes all the available textures for the material
  6. the MAT3 block reflects the material specifications, and that
  7. if the _GP.bgl is submitted to MCX, MCX reports the same material specifications as the custom material
Of course, if the custom material specification is in error, the GP is unlikely to display as expected.
 

Attachments

Top