P3D v3 [SOLVED] ADE does not compile GP with specular textures. (or bump)

MOUSY

Resource contributor
#1
So the manual says include appropriately named textures as _bump, _detail and _spec in your textures folder of ADE and the P3D compiler will automatically include them in the material settings of your compiled GP BGL, but I have tested this on 2 different material templates and 2 different textures and each time the bump and detail are included, but the specular is left out.
I am using ADE v0.1.75.6372 Beta and ADE-GP v 2.2.05.

specular 1.JPG

specular 3.JPG


specular 2.JPG
 

gadgets

Resource contributor
#2
The user manual is "wrong". The code is expecting the suffix "_specular", rather than just "_spec".

Since it's a lot easier to change the user manual than to re-issue the code, the former will be changed

Don
 

MOUSY

Resource contributor
#6
Instead of opening a new thread, I've edited the title, as this is a similar issue.

This time the material settings for a bump map are included in the object (they are visible in MCXs texture editor as seen above), but the bump effect does not show up in the simulator unless the GP BGL is opened and recompiled with MCX.
On the left is the GP directly out of ADE with detail, spec and (missing) bump effects. On the right is the same GP simply opened and re-exported.

bump map.jpg
It's not a major problem, as there is a work-around, but I just wanted to point it out in case anyone comes across this issue.
 

gadgets

Resource contributor
#7
You reported above that the bump map was being properly processed. What's the difference between that and this report?

Don
 

MOUSY

Resource contributor
#8
The difference is the material setting is present but the effect is not. Weird I know.

In picture #2 you can see that the bump map is present in the bump texture slot of MCXs Material Editor. But on opening the simulator, the effect does not show up. If I recompile the GP with MCX, the effect then appears.

P.S: This is unrelated to the specular problem I had earlier, as this now works correctly, with and without the bump map.
 

gadgets

Resource contributor
#12
The only relevant difference between the two objects is that the specular power in the ADE version is 0, while in the MCX version, specular power is non-zero (4842h) - which may be a default value. Please confirm whether or not the specular power in your ADE material settings is non-zero. If it is zero, try setting it to, say 50, and try again.

Don
 

gadgets

Resource contributor
#14
That is the only difference in the MATE section of the .bgl file related to the bump map. The bump map texture index is OK. There are some other differences regarding diffuse alpha which I didn't comment on before. In the ADE version, alpha_test_function, alpha_test_threshold and final_alpha_multiply are all 0 whereas in the MCX version, they are all 1s. Perhaps these are necessary default values for the bump map to work. Please set them to 1 with the material editor and try again.

Don
 

MOUSY

Resource contributor
#15
I set those too Don. No difference. All the settings are now identical between the 2 BGLs when compared via the material editor. Yet still, one of them does not show a bump effect in sim.
 

gadgets

Resource contributor
#16
I'm stumped for the moment, but not yet ready to give up. Please send me the final version with all those parameters set, so I can compare the .bgls.

Don
 

gadgets

Resource contributor
#18
Got it. I'll let you know if I find anything.

Don

PS: I notice the guids differ between the original and latest ADE versions.
 
Last edited:

gadgets

Resource contributor
#19
There is a, perhaps significant, difference between the original ADE version and the latest - other than the issues we have discussed. That is, the specular alpha value is now 0; it used to be non-0. The screenshot above shows that alpha as 255. and that's what was recorded in the original version.

If the alpha in the specular RGBA field in the Material Editor is now 0, please set it to 255 and try again. If it is not 0, then please send the .ad4 file.

Don
 
Top