Does GPW convert correctly?

#1
Hello Arno! I apologize for the intrusiveness and i really respect and appreciate your time, but probably nobody besides you will help me ... I didn’t want to litter the forum with similar topics, but probably I’ll have to create it here. I really hope that you will help me and for this I have already collected all the files necessary for your viewing and testing.
I will tell you a little about the problem and to understand the essence of the problem, see a short video please. After conversion, the runway textures are partially lost. But I must say that I always use several layers, like many developers here. For the test, I provide a material consisting of 2 layers, and in one of them, in order to visualize the volume of concrete slabs, I added the normal texture of the bulge to the cell. In Prepar 4.3 it works well, and in 4.4 I cannot do it fully due to the problem I am having This happens in places where the MCX divides a polygon into shares and groups of polygons. All the time I thought that the problem is because of the multi-layered, but it turns out this problem exists with one layer!
It looks like this


If you remove the check mark from this function, then the texture disappears only at the beginning and at the end of the runway. Can I transfer you my test work files for review? I want to make sure that it's not exactly MCX. Help me please understand this.

Sorry for my English
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#2
Hi,

Which output format of the GPW are you using? Do you test with the same file in P3D v3 and P3D v4 or with different files?
 
#3
I am using BGL output format
I do not use P3d v3.
I tested my project for version 4.3 in version 4.4 for the sample. This was immediately after the release of the new version of Prepar. But now I am doing a separate project only for version 4.4, because of the changes in the light, textures in this project were displayed slightly incorrectly, unlike v 4.3.
 
#4
I want to add, I tried the flatten, the exclud airport airport background, and even made the file of the height of the default airport - nothing helped
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#5
But are you using the same BGL in 4.3 and 4.4? Or did you use the v4 option in the GPW for one and the v4.4 option in the GPW for the other?
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#7
But you don't answer my question. If I don't know what combination of settings you use when you have the problem, how do you expect that I can reproduce something here?
 
#8
Arno, the biggest problem on the video. Of course, I can ignore this error and leave as it is now, and continue to model. But I cannot explain to people later that I could not win this error, as many believe that this problem is not complicated and can be solved in 5 minutes. I already shared files with experienced developers, and we lost a day together to solve this problem, but to no avail. I was hoping for a new SDK patch (4.4.16.27106), but as it turned out, the patch did not solve the problem.
 
Last edited:
#11
I did a primitive runway in 3D MAX. cloned a rectangle model as a copy and superimposed textures according to the layer order. First the concrete, then the dirt. At the same time, I export these two models to an X file and, using GPW, convert to BGL
 
#13
Hello Arno! I use 1 BGL for Prepar version 4.4 made with GPW P3D v 4. I also tried to install a tick on P3D v 4.4 and convert with the new SDK, but the result is that I can’t get rid of the disappearance of textures
I answered your question?
 
Last edited:

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#14
Hi,

At least I know which settings you used now.

You are sure you entered the right altitude in the GPW for your airport?

I'll try to reproduce it on my PC later today.
 
#16
I want to ask you to base my coordinates
Latitude 51.749759307
Longitude 36.295402944
Heading 33.91500
Altitude 209.092
I also noticed this feature - if I convert to GPW using the FSX button, and use BGL in Prepar 4.4, then there is no problem, only there are no shadows and the reflection of light from the sun on the runway
 

Attachments

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#19
Hi,

I can't reproduce the problem here on my PC. I did compile the ground polygons for P3D v4.4 with the default settings, but when I load them in the sim and move the viewpoint around I don't see any flickering. I have attached my file.
 

Attachments

#20
Thank you, Arno! I will test now
Textures do not disappear everywhere! Only in certain places of the runway. They need to be found on the runway
 
Last edited:
Top