• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

P3D v4 Rougness/Specular textures in MCX PBR material?

Hello everyone! I am not an expert in PBR, so I've got some problems.. I exported textures form quixel mixer, metalness workflow. I selected Albedo, Metalness, Normal.
1YOFhIN8gcs.jpg


Then I applied that textures to ground polygon and this is result in Prepar - surface is really ''wet''..
JahZnpmYs_o.jpg



I think this is because there is no reflection/roughness/specular textures, only black Metalness texture.. Where should I insert the texture that will be responsible for the reflectance in MCX, and what texture it must be?...

P.S. Sorry for my bad english
 

Pyscen

Resource contributor
Hello...

Not.knowing quixel mixer... I'm guess here... but the metallic map can have up to 3 maps within it. The 3 maps are metallic, ambient occlusion, and smoothness. The metallic map goes into the red channel. The ambient occlusion goes into the green channel. The Smoothness goes into the Alpha Channel. The blue channel should be black.

The Metallic and the Smoothness maps will control the reflective properties of the object. Depending on the values entered. In your case, the roughness will be the smoothness and might need to be inverted or reversed in colors (white for black or vice versa). This might be done within quixel, along with merging the 3 maps into one. If not, then any photo editor that has the ability the control the channels would do so, including the alpha channel.

Hope this will help..
 
Hello...

Not.knowing quixel mixer... I'm guess here... but the metallic map can have up to 3 maps within it. The 3 maps are metallic, ambient occlusion, and smoothness. The metallic map goes into the red channel. The ambient occlusion goes into the green channel. The Smoothness goes into the Alpha Channel. The blue channel should be black.

The Metallic and the Smoothness maps will control the reflective properties of the object. Depending on the values entered. In your case, the roughness will be the smoothness and might need to be inverted or reversed in colors (white for black or vice versa). This might be done within quixel, along with merging the 3 maps into one. If not, then any photo editor that has the ability the control the channels would do so, including the alpha channel.

Hope this will help..
Thank you for your reply! I tried it in quixel, but nothing changed... Then I went to photoshop and filled red, green and blue channels. Also I created Alpha channel. Sooo, how can I fill this channel with a texture?...
 

Pyscen

Resource contributor
Hello...

From within Photoshop, what is your meaning specifically on filled the red, green, and blue channels? You will need to learn how to copy a texture into the appropriate channel(s) within Photoshop. The Smoothness map (which is more than likely the roughness map that has been inverted or the reversed from quixel mixer), be copied into the Alpha channel. Unfortunately, I do not have the steps memorized or written down as of yet. Hopefully, someone has that for you readily available to you... In the meantime, I will try to have it written down (and tested, so I have it down correctly), and place it here.
 
Hello...

From within Photoshop, what is your meaning specifically on filled the red, green, and blue channels? You will need to learn how to copy a texture into the appropriate channel(s) within Photoshop. The Smoothness map (which is more than likely the roughness map that has been inverted or the reversed from quixel mixer), be copied into the Alpha channel. Unfortunately, I do not have the steps memorized or written down as of yet. Hopefully, someone has that for you readily available to you... In the meantime, I will try to have it written down (and tested, so I have it down correctly), and place it here.
Thank you very much! It would be very cool!
I copied textures to all channels except alpha... Here is the result. Once I was able to copy the texture to the alpha channel, and I managed to save the result. But for some reason, the alpha channel was not saved in png, but the "save alpha channel" checkbox was checked...
1555064414304.png
 

Pyscen

Resource contributor
How did you start out with the new texture? Did you start off with a new texture and then moved or copied the texture maps over to the new one?

I noticed in your image above that the alpha 1 isn't showing to be visible (the "eye" isn't showing).
 
How did you start out with the new texture? Did you start off with a new texture and then moved or copied the texture maps over to the new one?

I noticed in your image above that the alpha 1 isn't showing to be visible (the "eye" isn't showing).
Yes, I started new texture. I created 4096x4096 file. Then I added 3 layers with my textures.
1555077944799.png


Then I opened Blending options and assigned each layer to channel
1555078007655.png


I also created black layer for correct texture display.
1555078103685.png


Then I added alpha
1555078226413.png
I added inverted roughness to alpha
1555079006688.png

Then I saved as png, but checkbox Alpha channels can't be checked...
1555079614634.png

Now I figured out that only .tif format saves alpha channels, but file become really big (>60 mb)
 
I tried this .tif file. Here is result:( I also opened this new .tif file and alpha channel dissapeared after converting textures in MCX...
1555081649190.png
 

Pyscen

Resource contributor
What did you save the tif file to within MCX and why didn't you convert it in Photoshop? Sounds like it wasn't converted proper within MCX.
 
What did you save the tif file to within MCX and why didn't you convert it in Photoshop? Sounds like it wasn't converted proper within MCX.
I saved texture in photoshop as .tif file with this settings:
1555146862716.png

1555146899502.png

Then I imported them to MCX
1555147274641.png

After that I saved textures in specific folder
1555147394501.png
And result in simulator is in my previous post...
 
Top